28 декабря 2011

Используйте wp_enqueue_scripts

Если вы разработчик WordPress плагинов или шаблонов, то вам нужно знать что в версии 3.3 для подключения скриптов и css файлов рекомендуется использовать следующие хуки

  • wp_enqueue_scripts — для фронтенда (появился ещё в версии WP 2.6)
  • login_enqueue_scripts — для экрана регистрации (появился в версии WP 3.1)
  • admin_enqueue_scripts — для админки (появился ещё в версии WP 2.8)

Хуки из серии *_enqueue_styles появятся в WordPress 3.4, а пока используйте *_enqueue_scripts и для скриптов и для css.
Источник здесь

Статьи по теме
Статья оказалась полезной? Подпишись на RSS рассылку или следуй за мной на твиттере @wpstarter или по этой ссылке wpstarter

Оставьте комментарий

Обведите фигуру по линии:

Ставим WordPress на локальном копьютере